Upgrade Jest to 26.0.0 and Jest types to 26.6.0

- Clean the doubled up config settings, keeping .config.js
- Jest 27.0.0 is not yet compatible and throws the error

Test suite failed to run      TypeError: Cannot destructure property 'config' of 'options' as it is undefined. ... scripttransformer
3 jobs for 287-upgrade-jest-27-3-1-for-security-fix in 19 minutes and 58 seconds (queued for 7 seconds)
Status Name Job ID Coverage
  Build
passed install_dependencies #5114

00:09:07

 
  Lint
passed lint #5115

00:04:43

 
  Test
passed test #5116

00:06:07