Commit 34530cf1 authored by Penny Leach's avatar Penny Leach
Browse files

default require method is now require_once for safe_require

parent 1125a2ae
......@@ -583,7 +583,7 @@ function validate_username($username) {
* @param string $function (optional, defaults to require) the require/include function to use
* @param string $nonfatal (optional, defaults to false) just returns false if the file doesn't exist
*/
function safe_require($plugintype, $pluginname, $filename='lib.php', $function='require', $nonfatal=false) {
function safe_require($plugintype, $pluginname, $filename='lib.php', $function='require_once', $nonfatal=false) {
require_once(get_config('docroot') . $plugintype . '/lib.php');
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment