Commit 920adcb3 authored by Donal McMullan's avatar Donal McMullan
Browse files

New requires_config field in auth_installed table

parent f014d633
......@@ -20,6 +20,7 @@
<FIELD NAME="version" TYPE="int" LENGTH="10" NOTNULL="true" />
<FIELD NAME="release" TYPE="text" LENGTH="small" NOTNULL="true" />
<FIELD NAME="active" TYPE="int" LENGTH="1" NOTNULL="true" DEFAULT="1" />
<FIELD NAME="requires_config" TYPE="int" LENGTH="1" NOTNULL="true" DEFAULT="0" />
</FIELDS>
<KEYS>
<KEY NAME="primary" TYPE="primary" FIELDS="name" />
......
......@@ -262,6 +262,13 @@ function xmldb_core_upgrade($oldversion=0) {
execute_sql("ALTER TABLE {$prefix}view_access ALTER COLUMN accesstype SET DEFAULT 'public'");
}
if ($oldversion < 2007051500) {
$table = new XMLDBTable('auth_installed');
$field = new XMLDBField('requires_config');
$field->setAttributes(XMLDB_TYPE_INTEGER, 1, true, true, null, null, null, 0);
add_field($table, $field);
}
// everything up to here we pre mysql support.
return $status;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment