Commit e30f7d4c authored by Aaron Barnes's avatar Aaron Barnes
Browse files

composer: Run an install rather than update, and peg version numbers

This is a speedup for composer, as it's a bottleneck when switching
between patches frequently.

Change-Id: I2e4ab20d238671be3fe4c2a9be79b7def16a37d2
parent a1eeb3ea
......@@ -4,13 +4,13 @@
"behat/behat": "2.5.4",
"behat/mink": "1.6.0",
"behat/mink-extension": "*",
"behat/mink-extension": "1.3.3",
"behat/mink-goutte-driver": "*",
"behat/mink-selenium2-driver": "*",
"fabpot/goutte": "~1.0",
"behat/mink-goutte-driver": "1.1.0",
"behat/mink-selenium2-driver": "1.2.0",
"fabpot/goutte": "1.0.7",
"phpunit/phpunit": "3.7.*"
"phpunit/phpunit": "3.7.38"
}
}
......@@ -147,8 +147,8 @@ function testing_update_composer_dependencies() {
}
}
// Update composer dependencies.
passthru("php composer.phar update --dev", $code);
// Install/update composer dependencies.
passthru("php composer.phar install", $code);
if ($code != 0) {
exit($code);
}
......
......@@ -48,7 +48,7 @@ then
else
echo "Start Selenium..."
SELENIUM_VERSION_MAJOR=2.44
SELENIUM_VERSION_MAJOR=2.45
SELENIUM_VERSION_MINOR=0
SELENIUM_FILENAME=selenium-server-standalone-$SELENIUM_VERSION_MAJOR.$SELENIUM_VERSION_MINOR.jar
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment