Commit e4b63976 authored by Cecilia Vela Gurovic's avatar Cecilia Vela Gurovic Committed by Robert Lyon

Bug 1657565: New nav behat tests

behatnotneeded

Change-Id: Ifadc7e911efb905660c2a7bce0193551016a5fac
parent 5097eece
......@@ -83,8 +83,8 @@ $string['tab'] = 'tab';
$string['selected'] = 'selected';
$string['admin'] = 'Admin';
$string['menu'] = 'Menu';
$string['adminmenu'] = 'Administration menu';
$string['usermenu'] = 'User menu';
$string['adminmenu'] = 'Administration Menu';
$string['usermenu'] = 'User Menu';
$string['at'] = 'at';
$string['From'] = 'From';
......
......@@ -2976,18 +2976,18 @@ function main_nav($type = null) {
$menu = admin_nav();
}
}
else if ($USER->is_institutional_admin()) {
$menutype = 'instadmin_nav';
if (!($cachemenu = get_config_institution($institution, $menutype . '_' . $language))) {
$menu = institutional_admin_nav();
}
}
else if ($USER->get('staff')) {
$menutype = 'staff_nav';
if (!($cachemenu = get_config_institution($institution, $menutype . '_' . $language))) {
$menu = staff_nav();
}
}
else if ($USER->is_institutional_admin()) {
$menutype = 'instadmin_nav';
if (!($cachemenu = get_config_institution($institution, $menutype . '_' . $language))) {
$menu = institutional_admin_nav();
}
}
else {
$menutype = 'inststaff_nav';
if (!($cachemenu = get_config_institution($institution, $menutype . '_' . $language))) {
......
......@@ -60,6 +60,7 @@ class BehatGeneral extends BehatBase {
public function i_logout() {
$this->visitPath("/");
$this->wait_until_the_page_is_ready();
$this->i_click_on("Show User Menu");
$this->i_follow_in_the("Logout", "//header//li[contains(concat(' ', normalize-space(@class), ' '), ' btn-logout ')]", "xpath_element");
}
......
......@@ -59,13 +59,13 @@ class BehatNavigation extends BehatBase {
* @param string $menuitemtext the title of menu item e.g. "Content", "Portfolio".
* @return NodeElement
*/
protected function get_sub_menu_item_node($submenuitemtext, $menuitemtext) {
protected function get_sub_menu_item_node($submenuitemtext, $menuitemtext, $menu) {
// Avoid problems with quotes.
$submenuitemtextliteral = $this->escaper->escapeLiteral($submenuitemtext);
$menuitemtextliteral = $this->escaper->escapeLiteral($menuitemtext);
$exception = new ExpectationException('The sub menu item "' . $menuitemtext . ' not found or invisible in "', $this->getSession());
$xpath = "//nav[@id='main-nav']" .
$xpath = "//nav[@id='" . $menu . "']" .
"//li[contains(normalize-space(.), " . $menuitemtextliteral .")]" .
"//a[normalize-space(.)=" . $submenuitemtextliteral ."]";
$node = $this->find('xpath', $xpath, $exception);
......@@ -84,13 +84,35 @@ class BehatNavigation extends BehatBase {
$this->visitPath($path);
}
/**
* Choose a sub menu item in admnistration menu item
*
* @Given /^I choose "(?P<menu_item>(?:[^"]|\\")*)" in "(?P<mainmenu_item>(?:[^"]|\\")*)" from Admin menu$/
*/
public function i_choose_submenu_admin($menuitem, $mainmenuitem) {
$menuitemnode = $this->get_sub_menu_item_node($menuitem, $mainmenuitem, 'main-nav-admin');
$path = $menuitemnode->getAttribute('href');
$this->visitPath($path);
}
/**
* Choose a sub menu item in user menu item
*
* @Given /^I choose "(?P<menu_item>(?:[^"]|\\")*)" in "(?P<mainmenu_item>(?:[^"]|\\")*)" from User menu$/
*/
public function i_choose_submenu_user($menuitem, $mainmenuitem) {
$menuitemnode = $this->get_sub_menu_item_node($menuitem, $mainmenuitem, 'main-nav-user');
$path = $menuitemnode->getAttribute('href');
$this->visitPath($path);
}
/**
* Choose a sub menu item in a main menu item
*
* @Given /^I choose "(?P<menu_item>(?:[^"]|\\")*)" in "(?P<mainmenu_item>(?:[^"]|\\")*)"$/
* @Given /^I choose "(?P<menu_item>(?:[^"]|\\")*)" in "(?P<mainmenu_item>(?:[^"]|\\")*)" from Main menu$/
*/
public function i_choose_submenu($menuitem, $mainmenuitem) {
$menuitemnode = $this->get_sub_menu_item_node($menuitem, $mainmenuitem);
public function i_choose_submenu_main($menuitem, $mainmenuitem) {
$menuitemnode = $this->get_sub_menu_item_node($menuitem, $mainmenuitem, 'main-nav');
$path = $menuitemnode->getAttribute('href');
$this->visitPath($path);
}
......
......@@ -10,8 +10,7 @@ Feature: Mahara users can change their account settings
Scenario: Change notifications
Given I log in as "userA" with password "Kupuhipa1"
And I follow "Settings"
And I follow "Notifications"
And I choose "Notifications" in "Settings" from User menu
And I select "Email" from "activity_viewaccess"
When I press "Save"
And I should see "Preferences saved"
......
......@@ -8,7 +8,7 @@ Scenario: Editing admin profile page (Bug: 1426983)
# Log in
Given I log in as "admin" with password "Kupuhipa1"
# Updating Profile
When I follow "Content"
When I choose "Profile" in "Content" from Main menu
And I fill in the following:
| First name | Test |
| Last name | Admin |
......@@ -41,10 +41,11 @@ Scenario: Editing admin profile page (Bug: 1426983)
| Your URL or username | https://twitter.com/MaharaProject |
And I press "Save"
# Verifying the settings held, navitgating to dashboard page to check
And I click on "Show Menu"
Then I follow "Dashboard"
And I should see "Test Admin"
# Resetting/Editing details
And I follow "Content"
And I choose "Profile" in "Content" from Main menu
And I follow "About me"
And I fill in the following:
| First name | Admin |
......@@ -71,6 +72,7 @@ Scenario: Editing admin profile page (Bug: 1426983)
And I press "Save profile"
And I should see "Profile saved successfully"
# Verifying changes has been made navigating to dashboard page to checked
And I click on "Show Menu"
Then I follow "Dashboard"
And I should see "Admin User"
......@@ -78,7 +80,7 @@ Scenario: Editing admin profile picture (Bug: 1578000)
# Log in
Given I log in as "admin" with password "Kupuhipa1"
# Add new profile picture
When I choose "Profile pictures" in "Content"
When I choose "Profile pictures" in "Content" from Main menu
And I attach the file "Image2.png" to "Profile picture"
And I fill in the following:
| Image title | New avatar |
......
......@@ -11,8 +11,7 @@ Given the following "users" exist:
Scenario: Sending friend requests from student to admin (Bug 1440908)
Given I log in as "admin" with password "Kupuhipa1"
And I follow "Administration"
And I choose "User search" in "Users"
And I choose "User search" in "Users" from Admin menu
And I follow "Pete"
And I follow "Log in as userA"
And I follow "Admin User"
......@@ -22,6 +21,7 @@ And I press "Request friendship"
And I follow "Become Admin User again"
And I am on homepage
# In my inbox block I'll see "New friend request"
And I click on "Show User Menu"
And I follow "Inbox:"
And I expand the section "New friend request"
# Clicking on the notification title to expand it
......@@ -31,6 +31,7 @@ And I press "Approve request"
And I should see "Accepted friend request"
And I follow "Log in as userA"
# In userA's inbox block I'll see a "Friend request accepted" notification
And I click on "Show User Menu"
And I follow "Inbox:"
And I expand the section "Friend request accepted"
# Expanding it shows me another "More..." link which takes me to the inbox
......
......@@ -9,7 +9,7 @@ So people can have access to their Mahara
And the following "institutions" exist:
| name | displayname | registerallowed | registerconfirm |
| instone | Institution One | ON | ON |
And I follow "Logout"
And I log out
And I follow "Register"
And I fill in the following:
| First name | Lightening |
......@@ -21,7 +21,6 @@ So people can have access to their Mahara
And I press "Register"
And I follow "Login"
And I log in as "admin" with password "Kupuhipa1"
And I follow "Administration"
And I choose "Pending registrations" in "Institutions"
And I choose "Pending registrations" in "Institutions" from Admin menu
And I follow "Approve"
And I press "Approve"
@javascript @core @core_login
Feature: Suckypasswords Test increase of array size
In order to limit the crappy passwords people try to put in
As an admin
So I can make sure that my users/myself have decent passwords
@javascript @core @core_login
Feature: Suckypasswords Test increase of array size
In order to limit the crappy passwords people try to put in
As an admin
So I can make sure that my users/myself have decent passwords
Background:
Given the following "users" exist:
| username | password | email | firstname | lastname | institution | authname | role |
| userA | Kupuhipa1 | test01@example.com | Pete | Mc | mahara | internal | member |
Background:
Given the following "users" exist:
| username | password | email | firstname | lastname | institution | authname | role |
| userA | Kupuhipa1 | test01@example.com | Pete | Mc | mahara | internal | member |
Scenario: Admin can't change password to anything on suckypasswords list (Bug #844457)
Given I log in as "admin" with password "Kupuhipa1"
And I follow "Settings"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "abc123"
And I fill in "Confirm password" with "abc123"
And I press "Save"
And I should see "Your password is too easy"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "dragon"
And I fill in "Confirm password" with "dragon"
And I press "Save"
And I should see "Your password is too easy"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "administrator"
And I fill in "Confirm password" with "administrator"
And I press "Save"
And I should see "Your password is too easy"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "mahara"
And I fill in "Confirm password" with "mahara"
And I press "Save"
And I should see "Your password is too easy"
And I follow "Logout"
Scenario: Admin can't change password to anything on suckypasswords list (Bug #844457)
Given I log in as "admin" with password "Kupuhipa1"
And I click on "Show User Menu"
And I follow "Settings"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "abc123"
And I fill in "Confirm password" with "abc123"
And I press "Save"
And I should see "Your password is too easy"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "dragon"
And I fill in "Confirm password" with "dragon"
And I press "Save"
And I should see "Your password is too easy"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "administrator"
And I fill in "Confirm password" with "administrator"
And I press "Save"
And I should see "Your password is too easy"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "mahara"
And I fill in "Confirm password" with "mahara"
And I press "Save"
And I should see "Your password is too easy"
And I log out
Scenario: Student can't change password to anything on suckypasswords list (Bug #844457)
Given I log in as "userA" with password "Kupuhipa1"
And I follow "Settings"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "abc123"
And I fill in "Confirm password" with "abc123"
And I press "Save"
And I should see "Your password is too easy"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "dragon"
And I fill in "Confirm password" with "dragon"
And I press "Save"
And I should see "Your password is too easy"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "administrator"
And I fill in "Confirm password" with "administrator"
And I press "Save"
And I should see "Your password is too easy"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "mahara"
And I fill in "Confirm password" with "mahara"
And I press "Save"
And I should see "Your password is too easy"
And I follow "Logout"
Scenario: Student can't change password to anything on suckypasswords list (Bug #844457)
Given I log in as "userA" with password "Kupuhipa1"
And I click on "Show User Menu"
And I follow "Settings"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "abc123"
And I fill in "Confirm password" with "abc123"
And I press "Save"
And I should see "Your password is too easy"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "dragon"
And I fill in "Confirm password" with "dragon"
And I press "Save"
And I should see "Your password is too easy"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "administrator"
And I fill in "Confirm password" with "administrator"
And I press "Save"
And I should see "Your password is too easy"
And I fill in "Current password" with "Kupuhipa1"
And I fill in "New password" with "mahara"
And I fill in "Confirm password" with "mahara"
And I press "Save"
And I should see "Your password is too easy"
And I log out
......@@ -10,15 +10,14 @@ Scenario: Creating an Institution assigning users and changing their passwords
# Verifying log in was successful
And I should see "Admin User"
# Creating an Institution
When I follow "Administration"
And I follow "Institution"
And I click on "Show Administration Menu"
And I follow "Institutions"
And I press "Add institution"
And I fill in the following:
| Institution name | Institution One |
And I press "Submit"
# Creating user 1
And I follow "Users"
And I choose "Add user" in "Users"
And I choose "Add user" in "Users" from Admin menu
And I fill in the following:
| firstname | bob |
| lastname | bobby |
......@@ -29,8 +28,7 @@ Scenario: Creating an Institution assigning users and changing their passwords
And I enable the switch "Institution administrator"
And I press "Create user"
# Creating user 2
And I follow "Users"
And I choose "Add user" in "Users"
And I choose "Add user" in "Users" from Admin menu
And I fill in the following:
| firstname | Jen |
| lastname | Jenny |
......@@ -40,7 +38,7 @@ Scenario: Creating an Institution assigning users and changing their passwords
And I select "Institution One" from "Institution"
And I press "Create user"
# Log out as user admin
And I follow "Logout"
And I log out
# Log in as user 1
When I log in as "bob" with password "mahara1"
And I fill in the following:
......@@ -50,7 +48,7 @@ Scenario: Creating an Institution assigning users and changing their passwords
# Verifying password was changed successfully
And I should see "Your new password has been saved"
# Changing password
And I follow "Settings"
And I choose "Settings" in "Settings" from User menu
And I fill in the following:
| Current password | mahara2 |
| New password | mahara3 |
......@@ -59,7 +57,7 @@ Scenario: Creating an Institution assigning users and changing their passwords
# Verifying password was changed
And I should see "Preferences saved"
# Log out as user 1
And I follow "Logout"
And I log out
# Log in as user 2
And I log in as "jen" with password "mahara1"
And I fill in the following:
......@@ -69,7 +67,7 @@ Scenario: Creating an Institution assigning users and changing their passwords
# Verifying password was changed
And I should see "Your new password has been saved"
# Changing password
And I follow "Settings"
And I choose "Settings" in "Settings" from User menu
And I fill in the following:
| Current password | mahara2 |
| New password | mahara3 |
......
......@@ -14,10 +14,9 @@ Background:
Scenario: Accessing language string (Bug 1449350)
Given I log in as "admin" with password "Kupuhipa1"
And I follow "Administration"
And I click on "Show Administration Menu"
And I follow "Users"
And I check "selectusers_2"
And I press "Get reports"
When I press "Access list"
Then I should not see "[[loggedin/view]]"
......@@ -6,8 +6,7 @@ So I can benefit from the use of different configuration changes
Scenario: Turning switches on and off on the Add user page (Bug 1431569)
Given I log in as "admin" with password "Kupuhipa1"
And I follow "Administration"
And I choose "Add user" in "Users"
And I choose "Add user" in "Users" from Admin menu
And I set the following fields to these values:
| Site staff | 1 |
| Site administrator | 1 |
......
......@@ -10,8 +10,7 @@ Scenario: Create users by csv (Bug 1426983)
# Verifying log in was successful
And I should see "Admin User"
# Adding Users by CVS
When I follow "Administration"
And I choose "Add users by CSV" in "Users"
And I choose "Add users by CSV" in "Users" from Admin menu
And I attach the file "UserCSV.csv" to "CSV file"
And I disable the switch "Force password change"
And I disable the switch "Email users about their account"
......@@ -20,7 +19,7 @@ Scenario: Create users by csv (Bug 1426983)
And I should see "New users added: 4."
# Check that we can delete a user after upload (Bug #1558864)
And I choose "User search" in "Users"
And I choose "User search" in "Users" from Admin menu
And I follow "kevin01"
And I follow "Suspend or delete this user"
And I scroll to the id "delete"
......
......@@ -6,7 +6,8 @@ So I can make sure I can close/open site or clear cache
Scenario: Closing the site
Given I log in as "admin" with password "Kupuhipa1"
And I follow "Administration"
And I click on "Show Administration Menu"
And I follow "Admin home"
# Verifying I'm on the right page
And I should see "Register your Mahara site"
And I scroll to the base of id "close_site"
......
......@@ -6,8 +6,7 @@ I need to be able to turn switches on and off
Scenario: Turning swtitches on and off on Networking page (Bug 1431569)
Given I log in as "admin" with password "Kupuhipa1"
And I follow "Administration"
And I choose "Networking" in "Configure site"
And I choose "Networking" in "Configure site" from Admin menu
And I set the following fields to these values:
| Enable networking | 1 |
| Auto-register all hosts | 1 |
......
......@@ -18,5 +18,6 @@ Scenario: Checking that admin user can view messages in their mail sent from Con
And I trigger cron
And I go to the homepage
And I log in as "admin" with password "Kupuhipa1"
And I click on "Show User Menu"
And I click on "mail"
Then I should see "New contact us"
......@@ -6,8 +6,7 @@ I need to be able to enable it via a switch
Scenario: Turning the switches on and off on Cookie consent page (Bug 1431569)
Given I log in as "admin" with password "Kupuhipa1"
When I follow "Administration"
And I choose "Cookie Consent" in "Configure site"
And I choose "Cookie Consent" in "Configure site" from Admin menu
And I set the following fields to these values:
| Enable Cookie Consent | 1 |
And I press "Save changes"
......
......@@ -10,8 +10,7 @@ Scenario: Creating and deleting external links (Selenium 1426983)
# Verifying log in as successful
And I should see "Admin User"
# Entering an external link
When I follow "Administration"
And I choose "Menus" in "Configure site"
And I choose "Menus" in "Configure site" from Admin menu
And I select "Logged-in links and resources" from "Edit:"
And I fill in "namenew" with "Test Menu Link"
And I fill in "linkedtonew" with "https://mahara.org/"
......@@ -20,11 +19,10 @@ Scenario: Creating and deleting external links (Selenium 1426983)
And I should see "Item saved"
And I press "Save changes"
# Verifying the link as been added successfully
And I follow "Return to site"
And I click on "Show Menu"
And I follow "Dashboard"
Then I should see "Test Menu Link"
And I follow "Administration"
And I follow "Configure site"
And I choose "Menus" in "Configure site"
And I choose "Menus" in "Configure site" from Admin menu
And I select "Logged-in links and resources" from "Edit:"
#And I wait until the page is ready
#And I press "Delete"
......@@ -50,22 +48,21 @@ Scenario: Creating and deleting external links (Selenium 1426983)
Scenario: Make sure blogs do not show in site file link options (Bug #1537426)
# Log in as "Admin" user
Given I log in as "admin" with password "Kupuhipa1"
When I follow "Administration"
# I create a site journal
And I choose "Journals" in "Configure site"
And I choose "Journals" in "Configure site" from Admin menu
And I follow "Create journal"
And I fill in "Title" with "Site blog"
And I press "Create journal"
# I upload some site files
And I choose "Files" in "Configure site"
And I choose "Files" in "Configure site" from Admin menu
And I attach the file "Image1.jpg" to "File"
# Entering an external link
And I choose "Menus" in "Configure site"
And I choose "Menus" in "Configure site" from Admin menu
And I select "Logged-in links and resources" from "Edit:"
And I set the following fields to these values:
| Site file | 1 |
And the "linkedtonew" select box should not contain "Site blog"
And I press "Add"
\ No newline at end of file
And I press "Add"
......@@ -17,9 +17,9 @@ Scenario: Enable/disable external resources in mahara pages
# By default external resources are allowed in a page
When I log in as "userA" with password "Kupuhipa1"
# Upload an image
And I choose "Files" in "Content"
And I choose "Files" in "Content" from Main menu
And I attach the file "Image2.png" to "files_filebrowser_userfile"
And I choose "Pages and collections" in "Portfolio"
And I choose "Pages and collections" in "Portfolio" from Main menu
And I follow "Page 1"
And I follow "Edit this page"
......@@ -41,7 +41,7 @@ Scenario: Enable/disable external resources in mahara pages
| Block title | Text block with an external image |
| Block content | <p><img title="Open source logo" src="https://upload.wikimedia.org/wikipedia/commons/thumb/4/42/Opensource.svg/744px-Opensource.svg.png" alt="" width="300" /></p> |
And I press "Save"
And I scroll to the id "main-nav"
And I scroll to the id "main-column-container"
And I follow "Display page"
Then I should see images in the block "Text block with an internal image"
And I should see images in the block "Text block with an external image"
......@@ -49,14 +49,13 @@ Scenario: Enable/disable external resources in mahara pages
# Disable external resources and check if external images are displayed in pages
When I log in as "admin" with password "Kupuhipa1"
And I choose "Administration"
And I choose "Site options" in "Configure site"
And I choose "Site options" in "Configure site" from Admin menu
And I expand the section "Security settings"
And I enable the switch "Disable external resources in user HTML"
And I press "Update site options"
And I log out
And I log in as "userA" with password "Kupuhipa1"
And I choose "Pages and collections" in "Portfolio"
And I choose "Pages and collections" in "Portfolio" from Main menu
And I follow "Page 1"
Then I should see images in the block "Text block with an internal image"
And I should not see images in the block "Text block with an external image"
\ No newline at end of file
And I should not see images in the block "Text block with an external image"
......@@ -13,8 +13,8 @@ I can create a new page from the site default portfolio page
Scenario: Add a text block into the site default portfolio page and create a new portfolio page (Bug 1488255)
Given I log in as "admin" with password "Kupuhipa1"
When I follow "Administration"
And I choose "Pages and collections" in "Configure site"
And I click on "Show Administration Menu"
And I choose "Pages and collections" in "Configure site" from Admin menu
And I should see "Page template"
And I click on "Page template" panel menu
And I click on "Edit" in "Page template" panel menu
......@@ -33,6 +33,7 @@ I can create a new page from the site default portfolio page
And I should see "Login"
# Create a new portfolio page
And I log in as "userA" with password "Kupuhipa1"
And I click on "Show Menu"
And I choose "Portfolio"
And I should see "Pages and collections"
And I follow "Add"
......
......@@ -6,7 +6,7 @@ I need to expand all the fieldsets
Scenario: Expanding all the fieldsets
Given I log in as "admin" with password "Kupuhipa1"
When I follow "Administration"
And I click on "Show Administration Menu"
And I follow "Configure site"
Then I expand all fieldsets
And I should see "Event log expiry"
......@@ -6,8 +6,7 @@ So I can benefit from the use of group categories
Scenario: Turning switches on and off on group categories page (Bug 1431569)
Given I log in as "admin" with password "Kupuhipa1"
And I follow "Administration"
And I choose "Group categories" in "Groups (Administer groups)"
And I choose "Group categories" in "Groups" from Admin menu
# Flicking the switch to the opposite setting
And I set the following fields to these values:
| Enable group categories | 1 |
......
......@@ -6,7 +6,7 @@
Scenario:Injecting sql in groups search field
Given I log in as "admin" with password "Kupuhipa1"
And I follow "Groups"
And I choose "My groups" in "Groups" from Main menu
And I click on "Create group"
And I set the following fields to these values:
| Group name | <script>alert(1);</script> |
......@@ -15,12 +15,10 @@ Scenario:Injecting sql in groups search field
| Hide group | Off |
And I press "Save group"
And I should see "Group saved successfully"
And I follow "Administration"
And I follow "Groups"
And I choose "Administer groups" in "Groups" from Admin menu
When I set the following fields to these values:
| search_query | <script>alert(1);</script> |
And I press "search_submit"
And I follow "Privacy statement"
And I should see "Introduction"
Then I go to "homepage"
......@@ -17,9 +17,8 @@ Background:
Scenario: Viewing user statistics
Given I log in as "admin" with password "Kupuhipa1"
And I follow "Administration"
# Users without an institution
When I choose "Statistics" in "Institutions"
When I choose "Statistics" in "Institutions" from Admin menu
Then I should see "Institution statistics for 'Institution One'"
And I should see "Users 1"
# Users with an institution
......
......@@ -15,7 +15,7 @@ Scenario: Confirm that multiple notification choices are available (Bug #1299993
# Verifying log in was successful
And I should see "Admin User"
# Navigating to notification settings