Commit fd630ce8 authored by Aaron Wells's avatar Aaron Wells
Browse files

Dropping support for PHP 5.3

Bug 1576448. As discussed at the 52nd Mahara developer meeting.

behatnotneeded: Can't test in Behat (requires environmental
changes.)

Change-Id: I6cdfb0c154077f597128b7c3c1fd86b40b36c772
parent d093d7e6
......@@ -64,7 +64,7 @@ modification to support other databases.
### PHP
Mahara requires PHP version 5.3 or later. The "magic_quotes" and "register_globals"
Mahara requires PHP version 5.4 or later. The "magic_quotes" and "register_globals"
settings should be turned *off* (which is the default on modern PHP installations).
The following PHP extensions are also required:
......
......@@ -19,7 +19,7 @@ defined('INTERNAL') || die();
function ensure_sanity() {
// PHP version
$phpversionrequired = '5.3.0';
$phpversionrequired = '5.4.0';
if (version_compare(phpversion(), $phpversionrequired) < 0) {
throw new ConfigSanityException(get_string('phpversion', 'error', $phpversionrequired));
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment