Commit 239f222c authored by Aaron Wells's avatar Aaron Wells

Putting the 1.8 system requirements into the README file

Bug1234487

Change-Id: I56f1504bdc7d3f38abe254362d59998a84b62531
parent 719e12e6
Mahara Readme
-------------
Thanks for downloading Mahara! To install, please follow the instructions here:
Thanks for downloading Mahara!
SUPPORT: The best ways of obtaining support are:
* http://manual.mahara.org/ - the Mahara online manual
* http://www.mahara.org/forums - the Mahara project forums
* #mahara on freenode (IRC) - live chat with other users and developers
INSTALLATION:
To install, please follow the instructions here:
https://wiki.mahara.org/System_Administrator%27s_Guide/Installing_Mahara
UPGRADING:
If you already have a Mahara you wish to upgrade, follow the instructions here:
https://wiki.mahara.org/System_Administrator%27s_Guide/Upgrading_Mahara
The best ways of obtaining support are:
* #mahara on freenode (IRC) - live chat with other users and developers
* http://www.mahara.org/forums - the Mahara project forums
You can get language packs from:
SYSTEM REQUIREMENTS:
The system requirements for the most recent version of Mahara are here:
https://wiki.mahara.org/index.php/System_Administrator%27s_Guide/Requirements
Mahara 1.8 requires:
* Database:
** Postgres 8.3 or later
** or MySQL 5.1 or later
* Web Server: Mahara is only officially supported on Apache 2 or later,
although it will probably run in any web server with the proper PHP
extensions.
* PHP 5.3 or later, with the following extensions:
** gd (including Freetype support)
** json
** curl
** libxml
** SimpleXML
** session
** pgsql; or mysqli; or mysql
** openssl and xmlrpc (for networking support)
** mbstring
** mime_magic; or fileinfo
** mcrypt
** imagick (optional)
** zlib (optional)
** zip (optional)
** bz2 (optional)
** ... and ensure that the magic_quotes and register_globals settings are off.
* OS: Mahara is only officially supported on Debian (5.0/"Lenny" or later) and
Ubuntu (10.04/"Lucid Lynx" or later), however it will probably run in any
OS with a suitable web server
** For zip/unzip support, the command-line "zip" and "unzip" utilities must
be installed
* Web Browser: Mahara should be accessible in any modern web browser with
Javascript support. However, it is only actively tested in the most recent
versions of Firefox, Chrome, Safari, and Opera; and the last three versions
of IE. For Mahara 1.8.0, these versions are:
** Firefox - 24.0
** Chrome - 34.0
** Safari - 6.0
** Opera - 17.0
** IE - 8, 9, 10
TRANSLATIONS: You can get language packs from:
https://wiki.mahara.org/Download_Mahara
Documentation on integrating Mahara with Moodle can be found in the 3.1MB PDF
here:
MOODLE: Documentation on integrating Mahara with Moodle can be found in the
3.1MB PDF here:
https://wiki.mahara.org/images/d/d5/Mahoodle.pdf
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment