Commit 4af58e0d authored by Aaron Wells's avatar Aaron Wells

Make the "make ssphp" command more version-generic

Changing the "--transform" flag in tar to use a regex,
so that's one less place you have to specify the full
version.

Change-Id: I9d41ecc24f9d2116424be706e793f1f2618c35cf
parent 01283072
......@@ -62,7 +62,7 @@ ifdef simplesamlphp
@echo "SimpleSAMLphp already exists - doing nothing"
else
@echo "Pulling SimpleSAMLphp from download ..."
@curl -sSL https://github.com/simplesamlphp/simplesamlphp/releases/download/v1.14.3/simplesamlphp-1.14.3.tar.gz | tar --transform s/simplesamlphp-1.14.3/simplesamlphp/ -C htdocs/auth/saml/extlib -xzf -
@curl -sSL https://github.com/simplesamlphp/simplesamlphp/releases/download/v1.14.3/simplesamlphp-1.14.3.tar.gz | tar --transform 's/simplesamlphp-[0-9]+\.[0-9]+\.[0-9]+/simplesamlphp/x1' -C htdocs/auth/saml/extlib -xzf -
@php external/composer.phar --working-dir=htdocs/auth/saml/extlib/simplesamlphp update
endif
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment