Commit d20cba42 authored by Robert Lyon's avatar Robert Lyon Committed by Cecilia Vela Gurovic

Bug 1742579: Update readme to mention what maximum versions tested

for things like OS, database, PHP etc so user knows it might not workl
on too newer system

behatnotneeded

Change-Id: Ie3f70f74728718950954925d660f06357dbbc5e6
Signed-off-by: Robert Lyon's avatarRobert Lyon <robertl@catalyst.net.nz>
parent 4be48722
......@@ -60,10 +60,12 @@ Here are the system requirements needed to run Mahara 18.04.
### OS
Mahara is only officially supported on Debian (5.0/"Lenny" or later) and
Ubuntu (10.04/"Lucid Lynx" or later), however it will probably run in any
Mahara is only officially supported on Debian (7.0/"Wheezy" or later) and
Ubuntu (14.04/"Trusty Tahr" or later), however it will probably run in any
OS with a suitable web server.
Note: This version of Mahara has NOT been tested on Debian 9+ / Ubuntu 17.10+
### Web Server
Mahara is only officially supported on Apache 2 or later, although it will
......@@ -73,8 +75,12 @@ probably run in any web server with the proper PHP extensions.
Mahara requires either Postgres or MySQL. It would require extensive
modification to support other databases.
* Postgres 9.1 or later
* MySQL 5.1 or later (or MariaDB equivalent)
* Postgres 9.4 or later
* MySQL 5.6 or later
* MariaDB 10.0 or later
Note: This version of Mahara has NOT been tested on Postgres 10+, MySQL 8.0+,
MariaDB 10.3+ versions.
### PHP
......@@ -101,6 +107,8 @@ The following PHP extensions are also required:
* adodb (optional; improves performance)
* enchant or pspell (optional; for TinyMCE spellcheck button)
Note: This version of Mahara has not been tested on php versions 7.2+.
### Web Browser
Mahara should be accessible in any modern web browser with Javascript support.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment