Commit e138b32b by Robert Lyon

Bug 1717819: Update the readme file to have latest versiosn of browsers

Also make the minimum PHP version be 5.5.9

behatnotneeded

Change-Id: I784566d0a75ec7020ac61d3b6a56237fe4e2c670
Signed-off-by: Robert Lyon <robertl@catalyst.net.nz>
parent bc176a5f
......@@ -78,7 +78,7 @@ modification to support other databases.
### PHP
Mahara requires PHP version 5.4 or later. The "magic_quotes" and "register_globals"
Mahara requires PHP version 5.5.9 or later. The "magic_quotes" and "register_globals"
settings should be turned *off* (which is the default on modern PHP installations).
The following PHP extensions are also required:
......@@ -114,10 +114,10 @@ available.
For Mahara 18.04, the supported browser versions are:
// TODO: Review list of browsers closer to the release date.
* Firefox - 48.0
* Chrome - 51.0
* Safari - 9.1
* Opera - 39.0
* Firefox - 56.0
* Chrome - 61.0
* Safari - 11
* Opera - 47.0
* IE - 11 and Edge
* Safari for iOS
* Chrome for Android
......
......@@ -19,7 +19,7 @@ defined('INTERNAL') || die();
function ensure_sanity() {
// PHP version
$phpversionrequired = '5.4.0';
$phpversionrequired = '5.5.9';
if (version_compare(phpversion(), $phpversionrequired) < 0) {
throw new ConfigSanityException(get_string('phpversion', 'error', $phpversionrequired));
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment